import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z_\\x7f-\\xff\\d]";
final String string = "Building Wire/MC\n"
+ "OSHA 30\n"
+ "EMT 1/2\" to 2\"\n"
+ "EMT 2 1/2\" to 4\"\n"
+ "Cooperation & Conduct";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}