# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^.*?\.com\/|(?<!^)\G)[^\/\h]*\K\//|/gm;t' <<< "/foo/bar/baz/xyz
http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz"