#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^.*?\.com/|(?<!^)\G)[^/\h]*\K/"
Local $sString = "/foo/bar/baz/xyz" & @CRLF & _
"http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)