const regex = new RegExp('(?:^.*?\\.com/|(?<!^)\\G)[^/\\h]*\\K/', 'gm')
const str = `/foo/bar/baz/xyz
http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);