import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^.*?\\.com/|(?<!^)\\G)[^/\\h]*\\K/";
final String string = "/foo/bar/baz/xyz\n"
+ "http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}