import Foundation
let pattern = #"(?:^.*?\.com/|(?<!^)\G)[^/\h]*\K/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/foo/bar/baz/xyz
http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)