use strict;
my $str = '/foo/bar/baz/xyz
http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz';
my $regex = qr~(?:^.*?\.com/|(?<!^)\G)[^/\h]*\K/~mp;
my $subst = '|';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";