re = /(?:^.*?\.com\/|(?<!^)\G)[^\/\h]*\K\//m
str = '/foo/bar/baz/xyz
http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result