#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$"
Local $sString = "12345" & @CRLF & _
"Yograj" & @CRLF & _
"Yograj123456" & @CRLF & _
"12345Yograj" & @CRLF & _
"12345Yograj12345" & @CRLF & _
"Yograj123456Yograj" & @CRLF & _
"Yograj123Varsolkar456789" & @CRLF & _
"123Yograj45678Varsolkar" & @CRLF & _
"A1B2C3D4e5f6g7h8i9j0" & @CRLF & _
"Yograj 890 Varsolkar 78455" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")