import Foundation
let pattern = #"^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12345
Yograj
Yograj123456
12345Yograj
12345Yograj12345
Yograj123456Yograj
Yograj123Varsolkar456789
123Yograj45678Varsolkar
A1B2C3D4e5f6g7h8i9j0
Yograj 890 Varsolkar 78455
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)