use strict;
my $str = '12345
Yograj
Yograj123456
12345Yograj
12345Yograj12345
Yograj123456Yograj
Yograj123Varsolkar456789
123Yograj45678Varsolkar
A1B2C3D4e5f6g7h8i9j0
Yograj 890 Varsolkar 78455
';
my $regex = qr/^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}