# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$"
test_str = ("12345\n"
"Yograj\n"
"Yograj123456\n"
"12345Yograj\n"
"12345Yograj12345\n"
"Yograj123456Yograj\n"
"Yograj123Varsolkar456789\n"
"123Yograj45678Varsolkar\n"
"A1B2C3D4e5f6g7h8i9j0\n"
"Yograj 890 Varsolkar 78455\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.