const regex = /^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\d{6}|(?:.*\\d){9})[A-Za-z\\d]+$', 'gm')
const str = `12345
Yograj
Yograj123456
12345Yograj
12345Yograj12345
Yograj123456Yograj
Yograj123Varsolkar456789
123Yograj45678Varsolkar
A1B2C3D4e5f6g7h8i9j0
Yograj 890 Varsolkar 78455
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}