using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$";
string input = @"12345
Yograj
Yograj123456
12345Yograj
12345Yograj12345
Yograj123456Yograj
Yograj123Varsolkar456789
123Yograj45678Varsolkar
A1B2C3D4e5f6g7h8i9j0
Yograj 890 Varsolkar 78455
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}