$re = '/^(?!.*\d{6}|(?:.*\d){9})[A-Za-z\d]+$/m';
$str = '12345
Yograj
Yograj123456
12345Yograj
12345Yograj12345
Yograj123456Yograj
Yograj123Varsolkar456789
123Yograj45678Varsolkar
A1B2C3D4e5f6g7h8i9j0
Yograj 890 Varsolkar 78455
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);