#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Сверхъестественное.*\[1080p\]"
Local $sString = "Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)" & @CRLF & _
"Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)" & @CRLF & _
"Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")