package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Сверхъестественное.*\[1080p\]`)
var str = `Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}