const regex = /Сверхъестественное.*\[1080p\]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Сверхъестественное.*\\[1080p\\]', 'gi')
const str = `Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}