re = /Сверхъестественное.*\[1080p\]/i
str = 'Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end