import re
regex = re.compile(r"Сверхъестественное.*\[1080p\]", flags=re.IGNORECASE)
test_str = ("Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)\n"
"Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)\n"
"Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")