import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Сверхъестественное.*\\[1080p\\]";
final String string = "Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)\n"
+ "Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)\n"
+ "Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}