import Foundation
let pattern = #"Сверхъестественное.*\[1080p\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)