using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Сверхъестественное.*\[1080p\]";
string input = @"Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]. (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}