#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b"
Local $sString = "block-name" & @CRLF & _
"block-name__elem" & @CRLF & _
"block-name_mod" & @CRLF & _
"block-name__elem_mod" & @CRLF & _
"" & @CRLF & _
"block" & @CRLF & _
"block__elem" & @CRLF & _
"block_mod" & @CRLF & _
"block__elem_mod"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")