const regex = /\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\\b', 'ig')
const str = `block-name
block-name__elem
block-name_mod
block-name__elem_mod
block
block__elem
block_mod
block__elem_mod`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}