using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b";
string input = @"block-name
block-name__elem
block-name_mod
block-name__elem_mod
block
block__elem
block_mod
block__elem_mod";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}