$re = '/\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b/i';
$str = 'block-name
block-name__elem
block-name_mod
block-name__elem_mod
block
block__elem
block_mod
block__elem_mod';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);