re = /\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\b/i
str = 'block-name
block-name__elem
block-name_mod
block-name__elem_mod
block
block__elem
block_mod
block__elem_mod'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end