import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:[a-z0-9-]+)(?:__[a-z0-9-]+)*)\\b";
final String string = "block-name\n"
+ "block-name__elem\n"
+ "block-name_mod\n"
+ "block-name__elem_mod\n\n"
+ "block\n"
+ "block__elem\n"
+ "block_mod\n"
+ "block__elem_mod";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}