#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)"
Local $sString = "00965 3214576 " & @CRLF & _
"* +965 3214576" & @CRLF & _
"* 009653214576" & @CRLF & _
"* +9653214576" & @CRLF & _
"* 3214576" & @CRLF & _
"* (+965)(3214576)" & @CRLF & _
"* (00965)(3214576)" & @CRLF & _
"* (+965) 3214576" & @CRLF & _
"* (00965) 3214576"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")