const regex = /((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\(?(?:00|\\+)?\\d{3}\\)?\\s?\\(?)?\\d{7}\\)?)', 'g')
const str = `00965 3214576
* +965 3214576
* 009653214576
* +9653214576
* 3214576
* (+965)(3214576)
* (00965)(3214576)
* (+965) 3214576
* (00965) 3214576`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}