package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)`)
var str = `00965 3214576
* +965 3214576
* 009653214576
* +9653214576
* 3214576
* (+965)(3214576)
* (00965)(3214576)
* (+965) 3214576
* (00965) 3214576`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}