import re
regex = re.compile(r"((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)")
test_str = ("00965 3214576 \n"
"* +965 3214576\n"
"* 009653214576\n"
"* +9653214576\n"
"* 3214576\n"
"* (+965)(3214576)\n"
"* (00965)(3214576)\n"
"* (+965) 3214576\n"
"* (00965) 3214576")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")