// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\(?(?:00|\+)?\d{3}\)?\s?\(?)?\d{7}\)?)").unwrap();
let string = "00965 3214576
* +965 3214576
* 009653214576
* +9653214576
* 3214576
* (+965)(3214576)
* (00965)(3214576)
* (+965) 3214576
* (00965) 3214576";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}