#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\G(\S+)( (?=\1(?: |\z)))?"
Local $sString = "abc abc abc defg abc h abc abc abc"
Local $sSubst = "hello$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)