const regex = /\G(\S+)( (?=\1(?: |\z)))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G(\\S+)( (?=\\1(?: |\\z)))?', 'g')
const str = `abc abc abc defg abc h abc abc abc`;
const subst = `hello$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);