import Foundation
let pattern = #"\G(\S+)( (?=\1(?: |\z)))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abc abc abc defg abc h abc abc abc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"hello$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)