using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G(\S+)( (?=\1(?: |\z)))?";
string substitution = @"hello$2";
string input = @"abc abc abc defg abc h abc abc abc";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}