re = /\G(\S+)( (?=\1(?: |\z)))?/
str = 'abc abc abc defg abc h abc abc abc'
subst = 'hello$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result