$re = '/\G(\S+)( (?=\1(?: |\z)))?/';
$str = 'abc abc abc defg abc h abc abc abc';
$subst = "hello$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;