import re
regex = re.compile(r"\G(\S+)( (?=\1(?: |\z)))?")
test_str = "abc abc abc defg abc h abc abc abc"
subst = "hello$2"
result = regex.sub(subst, test_str)
if result:
print(result)