# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b/$0#/g;t' <<< "(identifier1 identifier_2 23 4) ____ 33"