re = /\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b/
str = '(identifier1 identifier_2 23 4) ____ 33'
subst = '$0#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result