const regex = /\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!\\d+\\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\\b', 'g')
const str = `(identifier1 identifier_2 23 4) ____ 33`;
const subst = `$0#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);