$re = '/\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b/';
$str = '(identifier1 identifier_2 23 4) ____ 33';
$subst = "$0#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;