import Foundation
let pattern = #"\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(identifier1 identifier_2 23 4) ____ 33"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$0#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)