using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b";
string substitution = @"$0#";
string input = @"(identifier1 identifier_2 23 4) ____ 33";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}