#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b"
Local $sString = "(identifier1 identifier_2 23 4) ____ 33"
Local $sSubst = "$0#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)