use strict;
my $str = '(identifier1 identifier_2 23 4) ____ 33';
my $regex = qr/\b(?!\d+\b)[A-Za-z0-9]+(?:_[A-Za-z0-9]+)*\b/p;
my $subst = '$0#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";