import Foundation
let pattern = #"\\">(.*?)<\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<tr>\r\n\t\t<td class=\"printCell\">NOLES A/S</td><td class=\"printCell\">Plast, glas og beton</td><td class=\"printCell\">Grøn</td><td class=\"printCell\" align=\"center\">13-04-2012</td><td class=\"printCell\" align=\"center\"> </td>\r\n\t</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)